This incident has been resolved and the active Firebase outage that was impacting notification delivery for some Twilio customers is operating normally.
Posted Sep 01, 2026 - 06:06 PDT
Update
We have still seeing recovery in an active Firebase outage that is impacting notification delivery for some Twilio customers. Customers using Twilio products that rely on Firebase Cloud Messaging may experience disrupted or delayed notification delivery. Affected products may include:
This issue is related to an upstream Firebase service disruption and may affect push notification delivery to end users. Our teams are actively monitoring the situation and we will provide an update in another 30 minutes or as more information becomes available.
Posted Sep 01, 2026 - 05:38 PDT
Monitoring
We have started seeing recovery in an active Firebase outage that is impacting notification delivery for some Twilio customers. Customers using Twilio products that rely on Firebase Cloud Messaging may experience disrupted or delayed notification delivery. Affected products may include:
This issue is related to an upstream Firebase service disruption and may affect push notification delivery to end users. Our teams are actively monitoring the situation and we will provide an update in 30 minutes or as more information becomes available.
Posted Sep 01, 2026 - 05:08 PDT
Update
We are still experiencing an active Firebase outage that is impacting notification delivery for some Twilio customers. Customers using Twilio products that rely on Firebase Cloud Messaging may experience disrupted or delayed notification delivery. Affected products may include:
This issue is related to an upstream Firebase service disruption and may affect push notification delivery to end users. Our teams are actively monitoring the situation and we will provide an update in 1 hour or as more information becomes available.
Posted Sep 01, 2026 - 04:41 PDT
Investigating
We are currently experiencing an active Firebase outage that is impacting notification delivery for some Twilio customers. Customers using Twilio products that rely on Firebase Cloud Messaging may experience disrupted or delayed notification delivery. Affected products may include:
This issue is related to an upstream Firebase service disruption and may affect push notification delivery to end users. Our teams are actively monitoring the situation and we will provide an update in 1 hour or as more information becomes available.
Posted Sep 01, 2026 - 04:23 PDT
This incident affected: ACCOUNT SECURITY (Authy 2FA), PROGRAMMABLE VOICE US1 (Client Mobile US1), and PROGRAMMABLE MESSAGING (Notify, Conversations).