Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Asia Cell Iraq
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted May 31, 2020 - 23:43 PDT
      Update
      We are continuing to work with our carrier partner to investigate this issue that is causing delayed delivery of SMS to handsets in Iraq. We will provide further updates as more information becomes available.
      Posted May 30, 2020 - 22:37 PDT
      Update
      We are continuing to work with our carrier partner to investigate this issue that is causing delayed delivery of SMS to handsets in Iraq. Our next update will be at 10 PM PT.
      Posted May 30, 2020 - 14:04 PDT
      Update
      We are continuing to work with our carrier partner to investigate this issue that is causing delayed delivery of SMS to handsets in Iraq. Our next update will be at 2 PM PT.
      Posted May 30, 2020 - 07:58 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 23:59 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 17:18 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 05:30 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 02:14 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 28, 2020 - 22:22 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will continue to monitor this situation and will provide an update as soon as more information becomes available.
      Posted May 28, 2020 - 20:24 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Asia Cell Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted May 28, 2020 - 19:13 PDT