Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
We are no longer experiencing Super SIM network connectivity issues. This incident has been resolved.
Posted Oct 13, 2021 - 02:26 PDT
Monitoring
We are now seeing recovery of the network connectivity issue. We are continuing to monitor for service stability. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 13, 2021 - 02:01 PDT
Update
We are investigating an issue where devices using Super SIM may not be able to connect to the network. Devices with existing data sessions are not affected. We are actively working to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Oct 13, 2021 - 01:02 PDT
Investigating
Our monitoring systems have detected a potential issue with Super SIM connectivity issues. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 13, 2021 - 00:38 PDT
This incident affected: INTERNET OF THINGS (Super SIM).