Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS delivery delays to US Operators
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 22:33 PST
Update
We are still observing delay for delivery reports and are continuing to work with our carrier partners on a resolution.
Posted Dec 02, 2019 - 22:08 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 02, 2019 - 16:53 PST
Identified
We are currently observing MMS being delivered intact however still observing delivery report / status callback being delayed. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
Posted Dec 02, 2019 - 16:51 PST
Investigating
We are observing delivery delays for MMS sent to US Operators. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
Posted Dec 02, 2019 - 08:25 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).