We apologize for any inconvenience. The scheduled maintenance has been postponed, and we will share the new dates as soon as they’re available. Thank you for your understanding.
Posted Dec 04, 2025 - 02:26 PST
Update
Our Voice carrier partner in New Zealand and Australia is conducting a planned maintenance from 11 December 2025 at 03:00 PST until 11 December 2025 at 04:00 PST. During the maintenance window, there could be intermittent call disconnects or call failures from and to Twilio New Zealand and Australia phone numbers.
Posted Nov 30, 2025 - 23:55 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 30, 2025 - 23:55 PST
Scheduled
Our Voice carrier partner in New Zealand and Australia is conducting a planned maintenance from 11 December 2025 at 03:00 PST until 11 December 2025 at 04:00 PST. During the maintenance window, there could be intermittent call disconnects or call failures from and to Twilio New Zealand and Australia phone numbers.
Posted Nov 24, 2025 - 23:18 PST
This scheduled maintenance affected: CARRIER NETWORK (Voice, APAC).