Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Authy Voice Verification is Delayed
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Oct 05, 2017 - 08:25 PDT
      Identified
      The issue has been identified and a fix is being implemented.
      Posted Oct 05, 2017 - 08:04 PDT
      Investigating
      At this time our Engineers have identified an issue with Authy Voice Verification, we are working on a fix.
      Posted Oct 05, 2017 - 07:48 PDT
      This incident affected: ACCOUNT SECURITY (Authy 2FA).