Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Wataniya Kuwait
Incident Report for Twilio
Resolved
The service has been restored completely. This incident is resolved.
Posted Oct 06, 2020 - 04:07 PDT
Monitoring
We are seeing a gradual restoration of service. We will be monitoring the status and update again once full service has been restored.
Posted Oct 06, 2020 - 03:41 PDT
Update
We are no longer seeing delays to delivery of messages but message delivery reports are still missing. We are working with our carrier partner to resolve the issue. An additional update will be supplied in 16 hours or as soon as additional information becomes available.
Posted Oct 05, 2020 - 13:34 PDT
Update
We continue to see a degradation in the service. We are working with our carrier partner to resolve the issue. An additional update will be supplied in 8 hours or as soon as additional information becomes available.
Posted Oct 05, 2020 - 05:31 PDT
Investigating
We are still seeing delays in delivery. We are working with our carrier partner to resolve the issue. An additional update will be supplied in 4 hours or as soon as additional information becomes available.
Posted Oct 05, 2020 - 01:45 PDT
Monitoring
We are still seeing delays in delivery. We are working with our carrier partner to resolve the issue. An additional update will be supplied in 4 hours or as soon as additional information becomes available.
Posted Oct 05, 2020 - 01:36 PDT
Update
We are continuing to investigate this issue. Another update will be supplied in 2 hours or as soon as additional information becomes available.
Posted Oct 05, 2020 - 00:14 PDT
Update
Our engineers are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 04, 2020 - 22:15 PDT
Investigating
We are experiencing SMS delivery delays for when sending messages with pre-registered Sender ID to the Wataniya network in Kuwait. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 04, 2020 - 21:16 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).