Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Authy/Verify SMS Delivery Delays to Multiple Destinations
Incident Report for Twilio
Resolved
The issue related to Authy SMS delivery delay to multiple destinations has been resolved and Authy Service is operating normally at this time.
Posted Apr 27, 2021 - 13:13 PDT
Update
We are continuing our investigation and have discovered Account Security - Verify is affected by Authy SMS delivery delays issue.
Posted Apr 27, 2021 - 11:23 PDT
Update
Upon further investigation, it is confirmed that we experienced an elevated queue that caused SMS delivery delays with the Authy Application to multiple destinations for a subset of customers, impacting Russia, United Kingdom, Iran, Mexico and Germany the most. We have observed recovery in the overall delivery and will continue to monitor for stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 27, 2021 - 11:17 PDT
Monitoring
Authy SMS delivery to UK numbers is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 27, 2021 - 10:19 PDT
Update
We are continuing to investigate the Authy SMS delays to UK numbers. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 27, 2021 - 09:17 PDT
Update
We are experiencing SMS delivery delays with the Authy Application when sending a subset of messages to the UK. Our engineers are working to resolve the issue. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Apr 27, 2021 - 08:47 PDT
Investigating
Our monitoring systems have detected a potential issue with Authy SMS delays to UK numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 27, 2021 - 08:25 PDT
This incident affected: ACCOUNT SECURITY (Authy 2FA, Verify, Authy App).