Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delivery issue for messages sent towards Telkomsel Indonesia
Incident Report for Twilio
Resolved
Delivery issue for messages sent towards Telkomsel Indonesia has been resolved.
Posted 8 months ago. May 17, 2018 - 03:31 PDT
Monitoring
Our carrier partner has fixed the issue and restored the service towards Telkomsel Indonesia. We continue to monitor.
Posted 8 months ago. May 17, 2018 - 02:38 PDT
Identified
Our carrier partner has identified the issue on their platform and carrier partner is working on a fix to restore the service towards Telkomsel Indonesia. Next update will be provided in 1 hour.
Posted 8 months ago. May 17, 2018 - 02:21 PDT
Investigating
Our engineering team is investigating an issue with delivery of messages towards Telkomsel Indonesia. Our engineers have escalated with the carrier and carrier is investigating the issue.
Posted 8 months ago. May 17, 2018 - 01:53 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).