Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays on AT&T
Incident Report for Twilio
Resolved
We are closing this incident due to minimal impact.We will individually reach out to small group of customers for further follow-ups.
Posted Jan 05, 2021 - 13:31 PST
Investigating
We are experiencing MMS delivery delays to US AT&T from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 05, 2021 - 12:59 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America).