Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delayed Phone Number Billing in March for a Subset of Customers
      Incident Report for Twilio
      Resolved
      We have fully investigated the delayed billing of phone numbers in March issue, and it was determined that the impact was limited to a small set of customers, who will be contacted individually to address any concerns. All systems are operational.
      Posted Apr 13, 2021 - 12:48 PDT
      Update
      We are continuing to investigate delayed billing of phone numbers in March for a subset of customers. We expect to provide another update in 2 hours.
      Posted Apr 13, 2021 - 12:38 PDT
      Update
      We are investigating delayed billing of phone numbers in March for a subset of customers. We expect to provide another update in 60 minutes.
      Posted Apr 13, 2021 - 11:37 PDT
      Investigating
      We've become aware of a potential issue with phone number billing in the month of March for a small subset of customers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Apr 13, 2021 - 11:07 PDT
      This incident affected: TWILIO PLATFORM (Billing) and PHONE NUMBERS.