Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Increase in the Number of Completed Tasks Returned from the Public API for a Subset of Customers
Incident Report for Twilio
Resolved
Tasks have been purged and TaskRouter is operating normally at this time.
Posted Apr 23, 2021 - 10:15 PDT
Monitoring
Tasks have been purged in TaskRouter, the system is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Apr 23, 2021 - 09:45 PDT
Update
We have implemented a fix. Full recovery will take 24 hours as affected Tasks are purged. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 12:45 PDT
Identified
We continue to address the increase in the number of completed tasks returned from the public API or viewed in console with Twilio TaskRouter affecting a subset of customers. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 10:46 PDT
Monitoring
We continue to address the increase in the number of completed tasks returned from the public API or viewed in console with Twilio TaskRouter affecting a subset of customers. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 10:45 PDT
Identified
We are addressing the increase in the number of completed tasks returned from the public API or viewed in console with Twilio TaskRouter affecting a subset of customers. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 22, 2021 - 09:48 PDT
Update
We continue to investigate an increase in the number of completed tasks returned from the public API or viewed in console with Twilio TaskRouter for a subset of customers. We expect to have an update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 07:50 PDT
Update
We are investigating an increase in the number of tasks returned from the public API or viewed in console with Twilio TaskRouter for a subset of customers. We expect to have an update in 1 hour or as soon as more information becomes available.
Posted Apr 22, 2021 - 06:51 PDT
Investigating
Our monitoring systems have detected a potential issue with Twilio TaskRouter for a subset of customers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 22, 2021 - 06:18 PDT
This incident affected: FLEX (TaskRouter).