Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Degradation from Twilio Short Codes to US Carriers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery delays from Twilio Short Codes to US Carriers. This incident has been resolved.
      Posted Nov 30, 2021 - 02:33 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Operational, with delivery receipt delays for a subset of short codes)
      T-Mobile (status - Operational, with delivery receipt delays for a subset of Short Code)
      Sprint (status - Operational, with delivery receipt delays for a subset of Short Code)
      Verizon (status - Operational, with delivery receipt delays for a subset of Short Code)
      MetroPCS (status - Operational, with delivery receipt delays for a subset of Short Code)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 30, 2021 - 00:49 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Operational, with delivery receipt delays for a subset of short codes)
      T-Mobile (status - Operational, with delivery receipt delays for a subset of short codes)
      Sprint (status - Operational, with delivery receipt delays for a subset of short codes)
      Verizon (status - Operational, with delivery receipt delays for a subset of short codes)
      MetroPCS (status - Operational, with delivery receipt delays for a subset of short codes)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 22:30 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Operational, with delivery receipt delays for a subset of short codes)
      T-Mobile (status - Operational, with delivery receipt delays for a subset of short codes)
      Sprint (status - Operational, with delivery receipt delays for a subset of short codes)
      Verizon (status - Operational, with delivery receipt delays for a subset of short codes)
      MetroPCS (status - Operational, with delivery receipt delays for a subset of short codes)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 20:30 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Operational, with delivery receipt delays for a subset of Short Code)
      T-Mobile (status - Operational, with delivery receipt delays for a subset of Short Code)
      Sprint (status - Operational, with delivery receipt delays for a subset of Short Code)
      Verizon (status - Operational, with delivery receipt delays for a subset of Short Code)
      MetroPCS (status - Operational, with delivery receipt delays for a subset of Short Code)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 18:35 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Operational, with delivery receipt delays for a subset of Short Code)
      T-Mobile (status - Operational, with delivery receipt delays for a subset of Short Code)
      Sprint (status - Operational, with delivery receipt delays for a subset of Short Code)
      Verizon (status - Operational, with delivery receipt delays for a subset of Short Code)
      MetroPCS (status - Operational, with delivery receipt delays for a subset of Short Code)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 16:37 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Operational, with delivery receipt delays for a subset of Short Code)
      T-Mobile (status - Operational, with delivery receipt delays for a subset of Short Code)
      Sprint (status - Operational, with delivery receipt delays for a subset of Short Code)
      Verizon (status - Operational, with delivery receipt delays for a subset of Short Code)
      MetroPCS (status - Operational, with delivery receipt delays for a subset of Short Code)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 14:49 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Delayed from a subset of Twilio short codes, with delivery receipt delays)
      T-Mobile (status - Operational, with delivery receipt delays)
      Sprint (status - Operational, with delivery receipt delays)
      Verizon (status - Operational, with delivery receipt delays)
      MetroPCS (status - Operational, with delivery receipt delays)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 12:43 PST
      Update
      Please find the current MMS delivery status from Twilio short codes for the major carriers below:

      AT&T (status - Delayed from a subset of Twilio short codes)
      T-Mobile (status - Delayed from a subset of Twilio short codes)
      Sprint (status - Delayed from a subset of Twilio short codes)
      Verizon (status - Delayed)
      MetroPCS (status - Delayed from a subset of Twilio short codes)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 10:38 PST
      Investigating
      Due to sustained high traffic on the US carrier networks, we are currently experiencing MMS delivery delays from Twilio short codes.  Messages are queued due to capacity shortage and customers may see delays when sending to certain US carriers. 

      Please find the current delivery status for the major carriers below:
      AT&T (status - Delayed, with delivery receipt delays)
      T-Mobile (status - Delayed, with delivery receipt delays)
      Sprint (status - Delayed, with delivery receipt delays)
      Verizon (status - Delayed, with delivery receipt delays)
      MetroPCS (status - Delayed, with delivery receipt delays)

      We are actively working with our carrier partners to resolve the issue, and we will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 29, 2021 - 08:56 PST
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).