Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Messaging Callback Failures
      Incident Report for Twilio
      Resolved
      Twilio Messaging Callback was degraded for 18 minutes between 10:04 am and 10:22 am Pacific Time on 11/29/2024. During this period of time customers may have experienced status callbacks failures. The issue has now been resolved.
      Posted Nov 29, 2024 - 11:00 PST
      Monitoring
      Our engineers are currently investigating the customer impact of a retroactive issue with Status Callbacks. We will follow up and provide customer impact details within 2 hours.
      Posted Nov 29, 2024 - 10:51 PST