Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Message Log Retrieval Failures via API Endpoint /Messages
Incident Report for Twilio
Resolved
We are no longer experiencing 404 errors with Message Log Retrieval. This incident has been resolved.
Posted Nov 13, 2020 - 20:11 PST
Update
We continue to experience 404 errors for Message Log GET requests via the API Endpoint '/Messages'. Customers attempting to retrieve message records using the API and only passing the DateSent is less than parameter (DateSent). Our engineers are investigating the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 13, 2020 - 17:31 PST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2020 - 16:01 PST
Update
We are experiencing 404 errors for Message Log GET requests via the API Endpoint '/Messages'. Customers attempting to retrieve message records using the API and only passing the DateSent is less than parameter (DateSent). Our engineers are investigating the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 13, 2020 - 15:59 PST
Investigating
Our monitoring systems have detected a potential issue with Message Log Retrieval. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 13, 2020 - 15:09 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels).