Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
Delays listing recent Calls in Console and via REST API
Incident Report for Twilio
Resolved
This incident has been resolved. All services are functioning normally at this time.
Posted 16 days ago. Nov 03, 2017 - 10:30 PDT
Identified
A subset of customers are currently experiencing delays listing recent phone calls in Console and with the REST API. Inbound and outbound calls are unaffected.
Posted 16 days ago. Nov 03, 2017 - 08:59 PDT
This incident affected: Console and REST API.