Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 26, 2023 - 09:00 PDT
Scheduled
Philippines Voice Carrier Partner Maintenance Our Voice carrier partner in the Philippines is conducting a series of planned maintenances from 26 September 2023 at 09:00 PDT until 04 October 2023 at 13:00 PDT. During the maintenance window, there could be intermittent call failures to and from a subset of Twilio’s Philippines phone numbers.
Note, the maintenance will be carried out on each of the following dates and times:
26 September 2023 at 09:00 PDT until 26 September 2023 at 13:00 PDT
27 September 2023 at 09:00 PDT until 27 September 2023 at 13:00 PDT
03 October 2023 at 09:00 PDT until 03 October 2023 at 13:00 PDT
04 October 2023 at 09:00 PDT until 04 October 2023 at 13:00 PDT
Posted Sep 21, 2023 - 22:51 PDT
This scheduled maintenance affected: CARRIER NETWORK (Voice, APAC).