Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Call Failures to a Subset of Twilio Swiss Phone Numbers
Incident Report for Twilio
Resolved
The issue affecting inbound calls to Twilio Swiss Phone Numbers has been resolved, and the service is functioning normally at this time.
Posted Sep 17, 2020 - 10:38 PDT
Monitoring
Our carrier partner has made changes to resolve the issue causing some inbound calls to Twilio Swiss numbers to fail. We will continue to monitor to ensure a full recovery of the service. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 17, 2020 - 08:48 PDT
Update
Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update in 16 hours or sooner once more information becomes available.
Posted Sep 17, 2020 - 04:46 PDT
Update
Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update in 8 hours or sooner once more information becomes available.
Posted Sep 16, 2020 - 20:44 PDT
Update
Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update in 8 hours or sooner once more information becomes available.
Posted Sep 16, 2020 - 12:00 PDT
Update
Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update in 4 hours or sooner once more information becomes available.
Posted Sep 16, 2020 - 08:01 PDT
Update
We are observing that inbound calls to some Twilio Swiss numbers are failing. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 2 hours or sooner once more information becomes available
Posted Sep 16, 2020 - 06:03 PDT
Investigating
Our monitoring systems have detected a potential issue impacting inbound calls to Twilio Swiss numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 16, 2020 - 05:04 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).