Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Phone Number Purchasing Unavailable
Incident Report for Twilio
Resolved
Our engineering team has resolved the issue. Functionality to purchase new Twilio phone numbers, release numbers, port numbers and change address and identity mappings has been restored.
Posted 3 months ago. Nov 30, 2018 - 04:33 PST
Investigating
Phone number purchasing is currently unavailable. Customers will be unable to purchase new Twilio phone numbers, release numbers, port numbers or change address and identity mappings. Our engineering teams are actively working to resolve the issue. We will provide an update as soon as possible
Posted 3 months ago. Nov 30, 2018 - 04:08 PST
This incident affected: PHONE NUMBERS.