Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures and Delays to Nigeria's Airtel Network for a Subset of Customers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures nor delays to Airtel in Nigeria. This incident has been resolved.
Posted Mar 25, 2021 - 12:30 PDT
Monitoring
We are observing successful SMS delivery to the Nigeria Airtel network for the last 40 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 10:40 PDT
Update
We are experiencing SMS delivery failures and delays when sending to Nigeria’s Airtel network for a subset of our customers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 25, 2021 - 09:48 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS message delivery to the Nigeria Airtel network. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 25, 2021 - 09:23 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).