Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound SMS delivery failures for Yemen Mobile
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Feb 09, 2020 - 12:58 PST
Monitoring
We are observing recovery for messages in Yemen. We will continue to monitor the status and provide an update in 30 minutes.
Posted Feb 09, 2020 - 12:34 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 09, 2020 - 12:00 PST
Update
We are continuing to see message non-delivery towards Yemen Mobile. We have received information that this network is down.
We are working with our carrier partners and will update you as soon as we have more information.
Posted Feb 09, 2020 - 10:02 PST
Identified
The traffic is now degraded and we are observing non deliveries again. We have received information that this network is down.
We are working with our carrier partners and will update you as soon as we have more information.
Posted Feb 09, 2020 - 09:00 PST
Monitoring
We are now seeing traffic recovery and continue to monitor with our carrier partners.
Posted Feb 09, 2020 - 07:23 PST
Investigating
We have observed failed deliveries towards Yemen Mobile (421 03) starting at approximately 13:20 UTC.
Our engineers are investigating with our carrier partners and we will provide more updates as they become available.
Posted Feb 09, 2020 - 06:44 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).