Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Domestic SMS SenderId preservation degradation through Singapore Singtel network
Incident Report for Twilio
Resolved
We have observed a stable recovery in SenderId preservation. We’ll continue to monitor and will consider this incident as resolved.
Posted 11 days ago. Aug 07, 2019 - 23:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 days ago. Aug 07, 2019 - 22:52 PDT
Identified
We have detected an issue with the degradation of SenderId preservation when sending domestic SMS through Singapore Signtel network. We are working with our carrier partners to resolve the issue and will provide an update as soon as possible.
Posted 11 days ago. Aug 07, 2019 - 22:08 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).