Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Devices Using Super SIM May Experience Delays Booking Esim-Profiles
      Incident Report for Twilio
      Resolved
      We are no longer experiencing issues causing esim profiles booking delay. This incident has been resolved.
      Posted Sep 20, 2022 - 00:11 PDT
      Monitoring
      Our engineering team has put in a fix to address the issue causing esim profiles booking delay. We are seeing recovery and are continuing to monitor for service performance. We will provide another update in 30 minutes or sooner once more information becomes available.
      Posted Sep 19, 2022 - 23:41 PDT
      Update
      We continue investigating an issue where the customers may experience delays booking new esim-profiles. We are actively working to identify and resolve the issue. We will provide another update in 2 hours or sooner once more information becomes available.
      Posted Sep 19, 2022 - 22:13 PDT
      Update
      We are investigating an issue where the customers may experience delays booking new esim-profiles. We are actively working to identify and resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
      Posted Sep 19, 2022 - 21:13 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Delays when Creating New eSIM Order Profiles. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 19, 2022 - 21:00 PDT
      This incident affected: INTERNET OF THINGS (Super SIM).