The issue preventing 'Auto Recharge Successful' emails from sending has been resolved and Auto Recharge emails are operating normally at this time.
Posted Mar 27, 2026 - 09:31 PDT
Monitoring
'Auto Recharge Successful' emails are now operating/sending normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 27, 2026 - 09:01 PDT
Update
Our engineers have identified an issue affecting 'Auto Recharge Successful' emails and are working to deploy a fix. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 27, 2026 - 08:15 PDT
Identified
Our engineers have identified the issue 'Auto Recharge Successful' emails and are working to deploy a fix. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 27, 2026 - 07:15 PDT
Investigating
Our monitoring systems have detected a potential issue with customers receiving 'Auto Recharge Successful' emails. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Mar 27, 2026 - 07:07 PDT
This incident affected: TWILIO PLATFORM (Billing).