Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Some SMS Short Code Message Status Delivery Report Delays on US Cellular
      Incident Report for Twilio
      Resolved
      We are no longer seeing Message Status Delivery Report Delays on US Cellular from some Twilio Short Codes. This incident has been resolved.
      Posted Mar 14, 2020 - 10:26 PDT
      Monitoring
      We are experiencing Message Status Delivery Report Delays on US Cellular from some Twilio Short Codes. We are starting to see recovery and are working with our carrier partners to fully resolve this issue. We will provide further updates, as they become available.
      Posted Mar 14, 2020 - 09:40 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).