Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Ethio-Telecom in Ethiopia
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. This incident has been resolved.
      Posted Nov 29, 2022 - 03:54 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 02:12 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 22:00 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 14:00 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 10:04 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 08:04 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 28, 2022 - 07:04 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).