Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Updates to Messaging Logs Delayed
Incident Report for Twilio
Resolved
We are no longer seeing Message Logs to be delayed in populating via the Console and API requests. This incident has been resolved.
Posted Nov 11, 2020 - 18:30 PST
Update
Message Logs continue to be delayed in populating via the Console and API requests. Inbound and Outbound Message Delivery is not affected. Message Logs created after 6:00AM PST may be affected. This issue has been identified and we continue to monitor the situation to full recovery. We will provide another update in 2 hours or as soon as more information becomes available
Posted Nov 11, 2020 - 18:27 PST
Monitoring
Message Logs continue to be delayed in populating via the Console and API requests. Inbound and Outbound Message Delivery is not affected. Message Logs created after 6:00AM PST may be affected. This issue has been identified and we continue to monitor the situation to full recovery. We will provide another update in 4 hours or as soon as more information becomes available
Posted Nov 11, 2020 - 16:22 PST
Update
We continue to observe delays for updates to the Message Logs via the Console and API requests. Inbound and Outbound Message Delivery is not affected. Message Logs created after 6:00AM PST may be affected. Our oncall team is actively investigating the issue. We will provide another update in 2 hours or as soon as more information becomes available
Posted Nov 11, 2020 - 13:47 PST
Update
We are still observing delays for updates to the messaging logs. Inbound / outbound message delivery is not affected. Message Logs after 6:00AM PST may be affected. Our engineering team has been alerted and is actively investigating. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 11, 2020 - 11:40 PST
Update
We are observing delays for new messages published to the messaging logs. Our engineering team has been alerted and is actively investigating. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 11, 2020 - 10:42 PST
Update
We are continuing our investigation and have discovered Programmable Messaging SMS, MMS, and Messaging Channels are affected while the REST API is not.
Posted Nov 11, 2020 - 10:36 PST
Update
We are continuing our investigation and have discovered Programmable Messaging SMS, MMS, and Messaging Channels are affected while the REST API is not.
Posted Nov 11, 2020 - 10:36 PST
Investigating
Our monitoring systems have detected a potential issue with the Messaging resource of our REST API . Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 11, 2020 - 10:29 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels).