Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issue with Accounts and Organisation Invitations
Incident Report for Twilio
Resolved
The issue with accounts and organization invitations has been resolved and the system is operating normally at this time. We are resolving this incident.
Posted Sep 14, 2021 - 03:27 PDT
Monitoring
The accounts and organization invitations are now operating normally. We will continue to monitor for system stability. We’ll provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 14, 2021 - 01:29 PDT
Investigating
Our monitoring systems have detected a potential issue with accounts and organization invitations. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 14, 2021 - 01:03 PDT
This incident affected: TWILIO PLATFORM (Other).