Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issues with Account Balance Reflection for a Subset of Customers
Incident Report for Twilio
Resolved
The issue causing payment processing delays and accounts with inconsistent balances or account statuses has been resolved and payment processing is operating normally at this time. This incident has been resolved.
Posted Apr 21, 2021 - 08:33 PDT
Update
We continue to see recovery with the billing processing issue that was causing payment processing delays. Error rate has significantly subsided since the fix, and we are not seeing new accounts being affected. As a correction from previous status, a subset of accounts will see inconsistent balance or account status until the issue is fully resolved. We are monitoring the service will provide an update at 9:00AM PDT or as soon as the situation changes.
Posted Apr 20, 2021 - 21:01 PDT
Update
We are seeing recovery with the billing processing issue that was causing payment processing delays. As a correction from previous status, a subset of accounts will see inconsistent balance or account status until the issue is fully resolved. Error rate has significantly subsided since the fix, and we are monitoring the service. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 20, 2021 - 19:00 PDT
Update
We are seeing recovery with the billing processing issue that was causing payment processing delays. As a correction from previous status, a subset of accounts will see inconsistent balance or account status until the issue is fully resolved. Error rate has significantly subsided since the fix, and we are monitoring the service. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 20, 2021 - 17:00 PDT
Update
We are seeing recovery with the billing processing issue that was causing payment processing delays. As a correction from previous status, a subset of accounts will see inconsistent balance or account status until the issue is fully resolved. Error rate has significantly subsided since the fix, and we are monitoring the service. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 20, 2021 - 14:59 PDT
Monitoring
We are seeing recovery with the billing processing issue that was causing payment processing delays. Account balance should now accurately reflect the successful payment made earlier. Error rate has significantly subsided since the fix, and we are monitoring the service for 30 minutes to ensure a full recovery.
Posted Apr 20, 2021 - 14:25 PDT
Update
We continue to experience payment processing delays on Twilio platform. A small subset of customers may not see account balance being reflected real time after a payment is made. The payment processing delays may also impact account reactivation. Our engineering team has taken measures to proactively monitor and prevent improper account suspension. Your account balance may be negative while the payment is being processed. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 20, 2021 - 13:39 PDT
Identified
We continue to experience payment processing delays on Twilio platform. A small subset of customers may not see account balance being reflected real time after a payment is made. The payment processing delays may also impact account reactivation. Our engineering team has taken measures to proactively monitor and prevent improper account suspension. Your account balance may be negative while the payment is being processed. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 20, 2021 - 12:39 PDT
Update
We continue to experience payment processing delays on Twilio platform. A small subset of customers may not see account balance being reflected real time after a payment is made. The payment processing delays may also impact account reactivation. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 20, 2021 - 11:33 PDT
Update
We continue to experience payment processing delays on Twilio platform. A small subset of customers may not see account balance being reflected real time after a payment is made. The payment processing delays may also impact account reactivation. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 20, 2021 - 10:35 PDT
Update
We continue to experience payment processing delays on Twilio platform. A small subset of customers may not see account balance being reflected real time after a payment is made. The payment processing delays may also impact account reactivation. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 20, 2021 - 09:39 PDT
Update
We are experiencing payment processing delays on Twilio platform. A small subset of customers may not see account balance being reflected real time after a payment is made. The payment processing delays may also impact account reactivation. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 20, 2021 - 08:39 PDT
Investigating
Our monitoring systems have detected a potential issue with Twilio billing platform. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 20, 2021 - 07:45 PDT
This incident affected: TWILIO PLATFORM (Billing).