Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to the US T-Mobile Network from a Subset of Twilio Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending SMS to the T-Mobile US network from a subset of Twilio short codes. This incident has been resolved.
Posted Mar 26, 2021 - 12:05 PDT
Update
We continue to observe recovery in delivery delays when sending SMS to the T-Mobile US network from a subset of Twilio short codes. We are monitoring for any issues and will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 26, 2021 - 10:39 PDT
Monitoring
We are observing recovery in delivery delays when sending SMS to the T-Mobile US network from a subset of Twilio short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 26, 2021 - 10:19 PDT
Investigating
Our monitoring systems have detected a potential issue with delivery delays when sending SMS to the T-Mobile US network from a subset of Twilio short codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 26, 2021 - 09:55 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).