Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to United States Cellular Corp Using Toll Free numbers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays to United States Cellular Corp (311-220) using Toll Free numbers. This incident has been resolved.
Posted Apr 01, 2021 - 16:06 PDT
Monitoring
We are observing recovery in SMS delivery delays for Toll-Free SMS sent to United States Cellular Corp in the US.. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 01, 2021 - 14:08 PDT
Update
We are experiencing SMS delivery delays for Toll-Free SMS sent to United States Cellular Corp (311-220) in the US. We are working with our carrier partners to resolve the issue. We expect to provide an update in 1 hours or as soon as more information becomes available.
Posted Apr 01, 2021 - 13:24 PDT
Update
We are experiencing SMS delivery delays for Toll-Free SMS sent to United States Cellular Corp (311-220) in the US. We are working with our carrier partners to resolve the issue. We expect to provide an update in 1 hours or as soon as more information becomes available.
Posted Apr 01, 2021 - 12:05 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to United States Cellular Corp (311-220) using Toll Free numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 01, 2021 - 12:02 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Toll-Free, North America, SMS Delivery Notifications & Status Callbacks) and PROGRAMMABLE MESSAGING (SMS).