Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay and Failure to Expresso Senegal
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery Delay and Failure when sending messages to Expresso Senegal. This incident has been resolved.
      Posted Jun 14, 2022 - 09:27 PDT
      Monitoring
      We are observing recovery in SMS delivery Delay and Failure when sending messages to Expresso Senegal. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 14, 2022 - 07:29 PDT
      Investigating
      We are continuing experiencing SMS delivery delay and failure when sending messages to Expresso Senegal. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted Jun 14, 2022 - 02:52 PDT
      Update
      We are continuing experiencing SMS delivery delay and failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 18:51 PDT
      Identified
      We are continuing experiencing SMS delivery delay and failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 14:51 PDT
      Update
      We are continuing experiencing SMS delivery delay and failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 13:17 PDT
      Monitoring
      We are continuing experiencing SMS delivery Delay and Failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 11:09 PDT
      Investigating
      After some hours of monitoring, we are continuing experiencing SMS delivery Delay and Failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 13, 2022 - 10:09 PDT
      Update
      We are observing recovery in SMS delivery Delay and Failure when sending messages to Expresso Senegal. We will continue monitoring the service to ensure a full recovery. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 13, 2022 - 09:02 PDT
      Update
      We are observing recovery in SMS delivery Delay and Failure when sending messages to Expresso Senegal. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 07:02 PDT
      Monitoring
      We are observing recovery in SMS delivery Delay and Failure when sending messages to Expresso Senegal. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 05:00 PDT
      Update
      We are continuing to work with our carrier partner to resolve SMS delivery Delay and Failure when sending messages to Expresso Senegal. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 01:03 PDT
      Update
      We continue to experience SMS delivery Delay and Failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 12, 2022 - 23:06 PDT
      Update
      We are experiencing SMS delivery Delay and Failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 12, 2022 - 22:06 PDT
      Investigating
      We are experiencing SMS delivery Delay and Failure when sending messages to Expresso Senegal. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 12, 2022 - 21:06 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).