Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
E911 Address Provisioning Failures
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted May 31, 2020 - 19:03 PDT
Update
We are continuing to work on a fix for this issue. We'll update this posting as more information becomes available.
Posted May 31, 2020 - 17:22 PDT
Identified
Our team has identified an issue preventing new addresses from being provisioned for E911. We're working with our partners to resolve the problem and we'll update this posting with more information as it becomes available.
Posted May 31, 2020 - 16:14 PDT
This incident affected: TWILIO PLATFORM (Other).