Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays on US - Verizon on a Small Subset of Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer observing issues in MMS delivery to US - Verizon when sending messages from a small subset of Twilio short codes. This incident has been resolved.
      Posted Oct 16, 2020 - 20:15 PDT
      Update
      We continue to observe successful MMS delivery to US - Verizon when sending messages from a small subset of Twilio short codes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 16, 2020 - 19:23 PDT
      Monitoring
      We are observing successful MMS delivery to US - Verizon when sending messages from a small subset of Twilio short codes for the last 30 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 16, 2020 - 17:21 PDT
      Update
      We continue to experience MMS delivery delays to US - Verizon when sending messages from a small subset of Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 16, 2020 - 15:21 PDT
      Investigating
      We are experiencing MMS delivery delays to US - Verizon when sending messages from a small subset of Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 16, 2020 - 14:26 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).