Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Failures to Airtel Network in Nigeria(621-20)
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Airtel network in Nigeria. This incident has been resolved.
      Posted Jul 31, 2021 - 07:15 PDT
      Monitoring
      We are observing recovery in SMS Delivery Delays and Failures when sending messages to Airtel Network in Nigeria(621-20). We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 31, 2021 - 05:40 PDT
      Investigating
      We are experiencing SMS Delivery Delays and Failures when sending messages to Airtel Network in Nigeria(621-20). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 31, 2021 - 05:01 PDT