The issue with the Support Center has been resolved, and the Support Center is loading over the Console window and operating normally at this time.
Posted Nov 10, 2023 - 12:24 PST
Monitoring
Support Center is loading now and operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 10, 2023 - 11:54 PST
Update
We are currently seeing degraded performance on our account portal, Support Center is not loading from Console when popups are blocked. Our engineering team is looking into the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 10, 2023 - 11:23 PST
Update
We are currently seeing degraded performance on our account portal, Support Center is not loading from Console when popups are blocked. Our engineering team is looking into the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
The loading screen has a workaround: To go back to Console, user's can still navigate within Console without issue To go to Twilio Help Center, user's can navigate to help.twilio.com manually
Posted Nov 10, 2023 - 10:29 PST
Investigating
We are currently seeing degraded performance on our account portal, Support Center is not loading from Console when popups are blocked. Our engineering team is looking into the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 10, 2023 - 10:19 PST
This incident affected: DEVELOPER TOOLS (Console) and TWILIO PLATFORM (Customer Support Center).