Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures To Blue Sky Communications Network In American Samoa
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures to Blue Sky Communications network in American Samoa. This incident has been resolved.
Posted Oct 12, 2021 - 05:19 PDT
Monitoring
We are observing successful SMS delivery Blue Sky Communications network in American Samoa for the last 60 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 12, 2021 - 03:28 PDT
Identified
The issue causing SMS delivery failures when sending messages to Blue Sky Communications network in American Samoa has been identified. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 12, 2021 - 02:29 PDT
Monitoring
We are observing successful SMS delivery Blue Sky Communications network in American Samoa for the 20 last minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 12, 2021 - 00:28 PDT
Update
We continue to experience SMS delivery failures when sending messages to Blue Sky Communications network in American Samoa . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Oct 11, 2021 - 17:14 PDT
Update
We continue to experience SMS delivery failures when sending messages to Blue Sky Communications network in American Samoa . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Oct 11, 2021 - 09:14 PDT
Update
We continue to experience SMS delivery failures when sending messages to Blue Sky Communications network in American Samoa . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Oct 11, 2021 - 05:07 PDT
Update
We continue to experience SMS delivery failures when sending messages to Blue Sky Communications network in American Samoa . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 11, 2021 - 03:09 PDT
Investigating
We are experiencing SMS delivery failures when sending messages to Blue Sky Communications network in American Samoa . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 11, 2021 - 02:10 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America) and PROGRAMMABLE MESSAGING (SMS).