Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound calls to Spanish Numbers Failing
Incident Report for Twilio
Resolved
This issue is now resolved
Posted May 13, 2020 - 06:02 PDT
Monitoring
We are beginning to see recovery. We will continue to monitor the situation and post any updates here.
Posted May 13, 2020 - 05:47 PDT
Investigating
We are experiencing failures for inbound calls toward a subset of our numbers in Spain. Our engineers are investigating the case with the underlying carriers. We will provide more information as soon as it becomes available.
Posted May 13, 2020 - 05:00 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).