Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delayed Emails to Support Teams
      Incident Report for Twilio
      Resolved
      This incident has now been resolved
      Posted Nov 17, 2019 - 08:53 PST
      Monitoring
      A fix has been deployed for the delayed emails to support teams and we have seen improvement. We are monitoring to ensure stability and will provide an update as soon as we have one.
      Posted Nov 16, 2019 - 09:41 PST
      Identified
      We've identified the issue impacting customers attempting to email some of our support teams. Engineering is working on a fix. We'll get back with an update on this as soon as we can.
      Posted Nov 15, 2019 - 14:15 PST
      Investigating
      We've detected an issue impacting customers attempting to email some of our support teams. Engineering is investigating and we'll provide an update as soon as possible.
      Posted Nov 15, 2019 - 13:53 PST
      This incident affected: TWILIO PLATFORM (Customer Support Center).