Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Calls to some US phone numbers in North America are failing
      Incident Report for Twilio
      Resolved
      All services have fully recovered and are operating normally.
      Posted Mar 14, 2018 - 15:21 PDT
      Monitoring
      We are observing calls to our carrier partner connecting again. Our engineering team is continuing to work with the carrier partner until the issue is confirmed to be fully resolved. We will provide another update in 1 hour.
      Posted Mar 14, 2018 - 14:59 PDT
      Update
      Our engineering team is continuing to work with our carrier partner to resolve the issue. We will post another update in 1 hour.
      Posted Mar 14, 2018 - 14:40 PDT
      Identified
      Currently a small percentage of Twilio North American phone numbers are not able to receive inbound calls. We are working with our carrier partner to resolve the issue.
      Posted Mar 14, 2018 - 13:42 PDT
      This incident affected: PROGRAMMABLE VOICE (PSTN).