Our engineers have monitored the fix and confirmed the issue with WhatsApp templates has been resolved. All services are now operating normally at this time.
Posted May 20, 2026 - 16:15 PDT
Monitoring
Our engineers have deployed a fix for the issue causing delays in Twilio/Flows template approvals on WhatsApp. We are now monitoring the service to ensure stability and confirm that the issue is fully resolved. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 20, 2026 - 14:28 PDT
Update
Our engineers have identified an issue where customers may experience a delay in getting Twilio/Flows templates approved on WhatsApp and are still working to deploy a fix. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted May 19, 2026 - 19:06 PDT
Update
Our engineers have identified an issue where customers may experience a delay in getting Twilio/Flows templates approved on WhatsApp and are still working to deploy a fix. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted May 18, 2026 - 18:54 PDT
Update
Our engineers have identified an issue where customers may experience a delay in getting Twilio/Flows templates approved on WhatsApp and are still working to deploy a fix. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted May 18, 2026 - 15:12 PDT
Update
Our engineers have identified an issue where customers may experience a delay in getting Twilio/Flows templates approved on WhatsApp and are still working to deploy a fix. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 18, 2026 - 12:41 PDT
Identified
Our engineers have identified the issue where Customers may experience a delay in getting Twilio/flows templates approved on WhatsApp and are working to deploy a fix. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 18, 2026 - 11:42 PDT
This incident affected: PROGRAMMABLE MESSAGING (WhatsApp Messaging).