Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS delivery failures to T-Mobile and Verizon handsets in the United States
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Aug 18, 2018 - 08:12 PDT
      Monitoring
      We observe recovery in message delivery receipts for MMS to T-Mobile and Verizon handsets in the US. All systems are fully operational.
      Posted Aug 18, 2018 - 06:14 PDT
      Identified
      We observe recovery in MMS deliverability to T-Mobile and Verizon handsets in the US. Delivery receipts remain delayed. We continue to work with our carrier partner and will provide an update within 4 hours or as soon as we have additional information.
      Posted Aug 18, 2018 - 03:20 PDT
      Update
      We continue experiencing MMS delivery failures to T-Mobile and Verizon handsets in the US. We are working with our carrier partner and will provide an update within 2 hours or as soon as we have more information.
      Posted Aug 18, 2018 - 01:02 PDT
      Investigating
      We are experiencing MMS delivery failures to T-Mobile and Verizon handsets in the US. We are working with our carrier partner and will provide an update within 60 minutes or as soon as we have more information.
      Posted Aug 17, 2018 - 23:55 PDT
      This incident affected: PROGRAMMABLE MESSAGING (MMS).