The incident has been resolved and SMS delivery from Twilio to affected networks in Malaysia and multiple countries in Africa is operating normally.
Posted Mar 05, 2026 - 20:23 PST
Update
We are observing recovery in SMS delivery delays from Twilio to network subscribers on multiple networks in multiple countries across APAC and Middle East & Africa. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 05, 2026 - 18:29 PST
Monitoring
We are observing recovery in SMS delivery delays from Twilio to network subscribers on multiple networks in multiple countries across APAC and Middle East & Africa. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 05, 2026 - 16:29 PST
Identified
We are continuing to experience SMS delivery delays from Twilio to network subscribers on multiple networks in multiple countries across APAC and Middle East & Africa. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 05, 2026 - 15:12 PST
Update
Twilio customers may be experiencing SMS delivery delays from Twilio to network subscribers on multiple networks in multiple countries across APAC and Middle East & Africa. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 05, 2026 - 14:20 PST
Investigating
Twilio customers may be experiencing SMS delivery delays from Twilio to network subscribers on multiple networks in multiple countries in Malaysia & Africa. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available
Posted Mar 05, 2026 - 14:12 PST
This incident affected: CARRIER NETWORK (SMS, APAC, SMS, Middle East & Africa).