Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Packet loss for inbound calls to UK numbers.
Incident Report for Twilio
Resolved
The issue has been resolved and the traffic is back to normal with no expected loss.
Posted Mar 24, 2020 - 06:06 PDT
Update
Our engineers are still investigating the issue with the underlying carrier. We will provide more information as soon as possible.
Posted Mar 24, 2020 - 04:23 PDT
Investigating
We are experiencing high traffic packet loss for inbound calls to the UK. our engineers are investigating the issue with the underlying carrier. We will provide more updates as soon as they become available.
Posted Mar 24, 2020 - 02:43 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).