Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
CNAM Registrations Failing
Incident Report for Twilio
Resolved
CNAM registrations are operating normally at this time.
Posted Oct 07, 2021 - 11:55 PDT
Monitoring
CNAM registrations are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 07, 2021 - 11:34 PDT
Update
Our engineers have identified the issue on our account portal with CNAM registrations failing and are working to deploy a fix. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Oct 06, 2021 - 18:32 PDT
Update
Our engineers have identified the issue on our account portal with CNAM registrations failing and are working to deploy a fix. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Oct 05, 2021 - 18:31 PDT
Identified
Our engineers have identified the issue on our account portal with CNAM registrations failing and are working to deploy a fix. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Oct 04, 2021 - 18:31 PDT
Update
We are currently seeing degraded performance on our account portal with CNAM registrations failing. Our engineering team is looking into the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 04, 2021 - 17:33 PDT
Investigating
Our monitoring systems have detected a potential issue with CNAM registrations failing. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 04, 2021 - 17:16 PDT
This incident affected: DEVELOPER TOOLS (Console).