Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and MMS Delivery Errors and Duplications Sending to US Verizon Toll Free Numbers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS and MMS delivery errors and duplication when sending to the US Verizon toll free numbers. This incident has been resolved.
      Posted May 25, 2022 - 11:43 PDT
      Monitoring
      We are no longer observing SMS and MMS delivery errors and duplication when sending to US Verizon toll free numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 09:50 PDT
      Update
      We continue to experience SMS and MMS delivery errors and duplication when sending to the US Verizon toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 08:47 PDT
      Update
      We are experiencing SMS and MMS delivery errors and duplication when sending to the US Verizon toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted May 25, 2022 - 07:45 PDT
      Investigating
      Our monitoring systems have detected a potential issue with MMS delivery. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 25, 2022 - 07:36 PDT
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America, MMS Toll-Free, North America).