Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS delivery failures for customers on IR-MCI Iran
      Incident Report for Twilio
      Resolved
      SMS delivery failures to IR-MCI Iran has been resolved and is operating normally at this time.
      Posted Jan 29, 2019 - 17:22 PST
      Investigating
      We are investigating delivery failures for customers on the IR-MCI Iran carrier network. We are working with our carrier partners to resolve.
      Posted Jan 29, 2019 - 15:03 PST