Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Message Status Event Steams Issue

        Incident Report for Twilio

        Resolved

        Message Status Event Steams events were degraded on 2nd April 2025 between 06:30 AM UTC and 08:10 AM UTC. During this period of time customers may have not received ~3.6% of status updates for outbound messages through Event Streams. The issue has now been resolved.
        Posted Apr 02, 2025 - 01:43 PDT

        Investigating

        Our monitoring systems have detected a potential issue with a subset of Event Streams events failing. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
        Posted Apr 02, 2025 - 01:18 PDT