Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Increased API Latency impacting Call Resources
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 8 months ago. Jun 25, 2018 - 11:18 PDT
Monitoring
REST API latency has returned to normal levels. Our engineers will continue monitoring the system.
Posted 8 months ago. Jun 25, 2018 - 10:22 PDT
Investigating
We are observing increased latency on a percentage of API requests impacting Call resources. Our engineers are investigating.
Posted 8 months ago. Jun 25, 2018 - 10:08 PDT
This incident affected: TWILIO PLATFORM (REST API).