Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Zambia MTN (645-02)
      Incident Report for Twilio
      Resolved
      Delivery delays when sending to Zambia MTN network (645-02) is resolved ands we have seen normal operation through monitoring window. This incident is resolved.
      Posted Mar 29, 2021 - 08:07 PDT
      Monitoring
      We are observing recovery in delivery report delays when sending to Zambia MTN network (645-02). We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Mar 29, 2021 - 05:56 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to Zambia MTN network (645-02). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hour or as soon as more information becomes available.
      Posted Mar 29, 2021 - 05:03 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Zambia MTN network (645-02). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 29, 2021 - 04:08 PDT